Dokumentation OpenWRT Konfiguration (Kamikaze)
Minimale Netzwerk-Konfiguration
- Neueste Firmware herunterladen von X-Wrt (mit Web-Interface) oder OpenWrt (ohne Web-Interface)
Linksys WRT54GSv1: openwrt-wrt54gs-2.4-squashfs.bin, Asus WL-500gP: openwrt-brcm-2.4-squashfs.trx - Image flashen
- telnet 192.168.1.1
- passwd (root-passwort setzen fuer ssh-zugriff)
- vi /etc/config/network
config interface lan
option ipaddr <lan ip>
option netmask <netmask>
option dns "<nameserver 1> <nameserver 2>"
Mit PPPoE:
config interface wan
option ifname eth1
option proto pppoe
option username '<user>'
option password '<pass>'
option defaultroute 1
option ppp_redial persist
Mit statischer IP:
config interface wan
option proto static
option ipaddr <wan ip>
option netmask <netmask>
option gateway <gateway>
- reboot
- ssh <lan ip>
Wifi-Konfiguration
- vi /etc/config/wireless
config wifi-device wl0
option disabled 0
config wifi-iface
option ssid <ssid>
option encryption psk2
option key <preshared key>
- reboot
1-1-NAT einrichten (falls mehrere fixe IP's verfuegbar)
Achtung: In neueren Versionen muss die Datei unter /etc/config/firewall aktiviert werden
- vi /etc/firewall.user
### ip-addressen hinzufuegen fuer 1-1-NAT
ifconfig $(uci get network.wan.ifname):0 add <wan-ip> netmask <netmask>
### 1-1-NAT
# postrouting_rule genommen, da posrouting_wan nicht geht
# /etc/init.d/firewall: [ -z "$WAN" ] || iptables -t nat -A POSTROUTING -i "$WAN" -j postrouting_wan
# iptables -A POSTROUTING mit Option -i --> Fehler
O2OWAN=<wan-ip>
O2OLAN=<lan-ip>
iptables -t nat -A prerouting_rule -d $O2OWAN/32 -j DNAT --to $O2OLAN
iptables -t nat -A postrouting_rule -s $O2OLAN -j SNAT --to $O2OWAN
iptables -A forwarding_rule -d $O2OLAN -j ACCEPT
- In neueren Versionen postrouting_rule zuerst verarbeiten
vi /lib/firewall/uci_firewall.sh
# $IPTABLES -A POSTROUTING -t nat -j postrouting_rule
$IPTABLES -I POSTROUTING 1 -t nat -j postrouting_rule
- reboot
Optionale Pakete installieren
Achtung: In neueren Versionen "opkg" statt "ipkg" verwenden.
- ipkg update
- ipkg install ntpclient tcpdump etherwake
QoS einrichten
- ipkg install qos-scripts
- vi /etc/config/qos.conf
- Fuer option download/upload sollte man beim Einsatz von PPPoE (z.B. ADSL) die Brottodatenrate in kbit/s durch 9 mal 7 verwenden (z.B. 6400/9*7=4978). Die maximal erreichbare Datenrate per FTP liegt bei ca. 93% des errechneten Wertes.
- reboot
name
wenn das wan interface ein dsl-anschluss ist und ppp0 dann alle 24h verloren geht, verbleiben die regeln in der firewall.